Global: Workpapers - some customers may be experiencing an error page when navigating Workpapers.

Incident Report for Xero

Resolved

Our team has resolved the issue impacting some partners trying to navigate in Workpapers. We apologise for any inconvenience this has caused.

A product release caused Workpapers to become unavailable, and a rollback restored service.
Posted May 22, 2026 - 04:45 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.
Posted May 22, 2026 - 04:25 UTC

Investigating

We are aware that some partners trying to navigate in Workpapers are experiencing an error page. Our team is investigating this with urgency.
Posted May 22, 2026 - 04:08 UTC
This incident affected: Xero Partner Products & Tools (Workpapers).