Some users experiencing performance issues in Xero
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 03:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2021 - 02:29 UTC
Update
We are continuing to investigate this issue.
Posted Nov 16, 2021 - 02:19 UTC
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users.
Posted Nov 16, 2021 - 01:52 UTC
Update
We are continuing to investigate this issue.
Posted Nov 16, 2021 - 00:40 UTC
Investigating
We are currently aware that users may be experiencing issues navigating through the platform, including receiving error messages and general slowness.
The Product team are investigating this with urgency.
Apologies for the inconvenience this is causing you - we'll update you as soon as we have any further updates.
Posted Nov 15, 2021 - 23:35 UTC
This incident affected: Xero.