Some users experiencing an Error 503 when accessing Reports
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Oct 30, 2016 - 19:43 UTC
Investigating
We're currently aware of an issue affecting a small number of our users when accessing the Reports feature of their Xero organisations. These users are receiving an Error 503, which is intermittent, and can be resolved by refreshing your web browsers window or clearing your web bowsers cookies and cache.

Our Product Team are working to fully resolve this issue with the highest priority.
Posted Oct 28, 2016 - 09:46 UTC