Some users are experiencing slowness in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was affecting the performance in Xero for some users.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted 21 days ago. Feb 28, 2019 - 17:36 NZDT
Update
We’re closer to sorting this out, sorry for the disruption this is causing you.
Posted 21 days ago. Feb 28, 2019 - 17:17 NZDT
Update
We're currently working to get the performance in Xero back to normal for everyone.
Thanks for your continued patience.
Posted 21 days ago. Feb 28, 2019 - 16:45 NZDT
Identified
Our Product Team have identified the cause, and are working to restore performance in Xero as soon as possible.
Posted 21 days ago. Feb 28, 2019 - 16:15 NZDT
Update
Our Product Team are doing everything they can to restore performance in Xero. Thanks for your patience.
Posted 21 days ago. Feb 28, 2019 - 15:48 NZDT
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted 21 days ago. Feb 28, 2019 - 15:29 NZDT
Update
We’re currently aware of an issue where some users are experiencing slowness in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted 21 days ago. Feb 28, 2019 - 15:11 NZDT
Investigating
We are currently investigating this issue.
Posted 21 days ago. Feb 28, 2019 - 15:08 NZDT
This incident affected: Xero.