Global: Reporting - some users are experiencing performance issues
Incident Report for Xero
Resolved
Our team has resolved the issue causing performance issues when loading reports in Xero. We apologise for any inconvenience this has caused.

Within 24 hours we’ll update this page with a brief summary
Posted Jan 31, 2024 - 06:53 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 6:38 am UTC
Posted Jan 31, 2024 - 06:39 UTC
Identified
We have identified what is impacting customers who are experiencing performance issues when loading reports in Xero

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 6:23 am UTC
Posted Jan 31, 2024 - 02:58 UTC
Investigating
We are aware some customers are experiencing performance issues when loading reports in Xero. Our team is investigating this with urgency.

Status Last Reviewed: 1:13am UTC
Posted Jan 31, 2024 - 01:13 UTC
This incident affected: Core Xero Products (Reporting).