Some users are unable to access Xero Central
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from accessing Xero Central.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Nov 06, 2019 - 17:47 NZDT
Investigating
We’re currently aware of an issue preventing users from accessing Xero Central. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Nov 06, 2019 - 17:45 NZDT
This incident affected: Xero Central.