Global: Xero - Some customers may be experiencing errors in Xero

Incident Report for Xero

Resolved

Our team has resolved the issue impacting customers trying to access Xero. We apologise for any inconvenience this has caused.

This was caused by a system upgrade, and the issue has now been resolved. We apologise for the inconvenience caused.
Posted Jul 01, 2024 - 20:02 UTC

Investigating

We are aware customers trying to load pages in Xero in are experiencing errors. Our team is investigating this with urgency.

Status Last Reviewed: 7:46pm UTC
Posted Jul 01, 2024 - 19:46 UTC
This incident affected: Xero Platform and Settings.