Global: Xero - Some customers may be experiencing errors accessing Xero
Incident Report for Xero
Resolved
Our team has resolved the issue impacting some customers from accessing Xero.

This was caused by a product release which was rolled back to resolve the issue. We apologise for any inconvenience this has caused.
Posted Aug 26, 2024 - 00:26 UTC
Investigating
We are aware some customers trying to access Xero are experiencing errors. Our team is investigating this with urgency.

Status Last Reviewed: 12:07am UTC
Posted Aug 26, 2024 - 00:07 UTC
This incident affected: Xero Platform and Settings.