Some users are experiencing issues logging in or navigating in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from logging into and navigating Xero.

If you're still having any problems, please clear your cookies and cache. Let us know if you continue to have issues, and we'll investigate further.
Posted May 04, 2020 - 04:04 UTC
Identified
Our Product Team have identified the cause, and are working to restore your access to Xero as soon as possible.
Posted May 04, 2020 - 04:00 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted May 04, 2020 - 03:15 UTC
Investigating
We’re currently aware of an issue preventing some users logging in or navigating in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted May 04, 2020 - 02:51 UTC
This incident affected: Xero.