Global: Online invoices- receiving an error
Incident Report for Xero
Resolved
Our team has resolved the issue impacting some global customers trying to open an online invoice in Xero. We apologise for any inconvenience this has caused.

A product release caused this feature to become unavailable. We've rolled back the release and services are back to normal.
Posted Jun 03, 2024 - 20:27 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 8:20pm UTC
Posted Jun 03, 2024 - 20:20 UTC
Identified
We have identified what is preventing some global customers from opening an online invoice in Xero.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 8:15pm UTC
Posted Jun 03, 2024 - 20:16 UTC
This incident affected: Core Xero Products (Invoicing, Bills & Quotes).