Global: Xero - Some customers experienced errors

Incident Report for Xero

Resolved

We are aware that customers may have experienced errors when accessing or using Xero between approximately 06:47 and 06:53 UTC. This issue has now been resolved.
Posted Jun 17, 2026 - 09:23 UTC

Monitoring

We are aware that customers may have experienced errors when accessing or using Xero between approximately 06:47 and 06:53 UTC. This has now resolved but we are monitoring the situation closely.
Posted Jun 17, 2026 - 07:43 UTC