Issue printing tax returns in Xero Tax
Incident Report for Xero
Resolved
Our Product Team have resolved the issue preventing AU Tax users from printing returns.

Please let us know if you still have any issues printing returns, and we’ll investigate further.
Posted 5 months ago. May 15, 2018 - 21:04 NZST
Update
Our Product Team are doing everything they can to resolve the AU Tax issue when printing returns. Thanks for your patience.
Posted 5 months ago. May 15, 2018 - 20:42 NZST
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted 5 months ago. May 15, 2018 - 20:23 NZST
Investigating
We are investigating reports of problems printing tax returns in Xero Tax due to unprecedented demand. Team is working to increase capacity.
Posted 5 months ago. May 15, 2018 - 19:41 NZST