Users experiencing issues processing batch payments
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from processing batch payments.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Jul 21, 2021 - 05:31 UTC
Update
Our Product Team are doing everything they can to let you process batch payments in Xero. Thanks for your patience.
Posted Jul 21, 2021 - 03:55 UTC
Investigating
We’re currently aware of an issue preventing users from processing their batch payments. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Jul 21, 2021 - 03:17 UTC
This incident affected: Xero.