Users experiencing slowness and performance issues in Hubdoc
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing slowness in Hubdoc.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Dec 11, 2020 - 00:02 UTC
Investigating
Some users may be experiencing slowness and performance issues in Hubdoc, we are investigating and will post an update as soon as we have more information.
Posted Dec 10, 2020 - 23:35 UTC
This incident affected: Xero Platform and Settings and Hubdoc.