HMRC has resolved the issue causing some filing delays through the UK Tax product.
Posted Nov 25, 2024 - 19:44 UTC
Monitoring
HMRC has implemented a fix and we are currently monitoring the results.
Status Last Reviewed:
Posted Nov 25, 2024 - 08:54 UTC
Update
We have confirmed that this is causing some filings to be delayed for CIS, Partnership Tax, Personal Tax and now Corporation Tax. We will continue to monitor this issue and provide updates.
Posted Nov 21, 2024 - 18:20 UTC
Investigating
We are aware HMRC are currently experiencing issues which may cause some filing delays through the UK Tax product. This has been escalated with HMRC and we will provide updates as these become available.