Some users experiencing slowness and errors in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from accessing Xero.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Feb 24, 2020 - 01:31 UTC
Identified
Our Product Team have identified the cause, and are working to restore your access to Xero as soon as possible.
Posted Feb 24, 2020 - 01:19 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Feb 24, 2020 - 01:03 UTC
Investigating
We’re currently aware of some users experiencing slowness and errors in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Feb 24, 2020 - 00:47 UTC
This incident affected: Xero.