Global: Xero - Customers may be experiencing slowness in Xero
Incident Report for Xero
Resolved
Our team has resolved the issue causing slowness across Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Nov 16, 2023 - 04:30 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 3:46 am UTC
Posted Nov 16, 2023 - 03:48 UTC
Investigating
We are aware customers may be experiencing slowness across Xero. Our team is investigating this with urgency.

Status Last Reviewed: 3:16 am UTC
Posted Nov 16, 2023 - 03:17 UTC
This incident affected: Xero Platform and Settings.