Global: Reports - some customers may be unable to reports
Incident Report for Xero
Resolved
Our team has resolved the issue impacting some customers trying to load reports. This was caused by a prior release and our team implemented a fix to resolve the issue. We apologise for any inconvenience this has caused.
Posted Feb 17, 2023 - 00:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2023 - 00:25 UTC
Identified
We have identified what is preventing some customers trying to load reports.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 11:51pm UTC
Posted Feb 16, 2023 - 21:37 UTC
Investigating
We are aware customers trying to load reports are experiencing issues loading them. Our team is investigating this with urgency.

Status Last Reviewed: 9:16pm UTC
Posted Feb 16, 2023 - 20:41 UTC
This incident affected: Core Xero Products (Reporting).