Global: Xero Practice Manager - customers may be experiencing slowness

Incident Report for Xero

Resolved

Our team has resolved the issue impacting our customers trying to navigate in Xero Practice Manager We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity issues, and our team has restored service.
Posted Apr 01, 2025 - 01:13 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 12:39am UTC
Posted Apr 01, 2025 - 00:39 UTC

Update

Our product team is looking into this, and we’ll provide an update as soon as possible.

Status Last Reviewed: 12:15am UTC
Posted Mar 31, 2025 - 23:46 UTC

Update

We are continuing to investigate this issue.
Posted Mar 31, 2025 - 23:37 UTC

Update

We are continuing to investigate this issue.
Posted Mar 31, 2025 - 23:32 UTC

Investigating

We are aware some customers trying to navigate in Practice Manager are experiencing slowness and some error pages. Our team is investigating this with urgency.

Status Last Reviewed: 11:24pm UTC
Posted Mar 31, 2025 - 22:58 UTC
This incident affected: Xero Platform and Settings and Xero Partner Products & Tools (Xero Practice Manager (XPM), Xero Tax (AU), Xero Tax (NZ)).