Some users are experiencing intermittent issues with Xero Central
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Oct 20, 2020 - 09:27 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Oct 20, 2020 - 05:18 UTC
Investigating
We’re currently aware of an issue where some users are encountering a blank screen in Xero Central. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Oct 20, 2020 - 04:13 UTC
This incident affected: Xero Central.