Global: Xero - Some users experiencing errors in Xero
Incident Report for Xero
Resolved
Our team has resolved the issue that was causing errors in Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Mar 04, 2024 - 19:02 UTC
Investigating
We are aware some customers are experiencing general errors and slowness in Xero. Our team is investigating this with urgency.

Status Last Reviewed: 6:49pm UTC
Posted Mar 04, 2024 - 18:49 UTC
This incident affected: Xero Platform and Settings.