Our team has resolved the issue impacting NZ customers trying to load their timesheets in Xero Payroll. We apologise for any inconvenience this has caused.
A product release caused this feature to become unavailable. We've rolled back the release and services are back to normal.
Posted Mar 17, 2024 - 23:53 UTC
Investigating
We are aware NZ customers trying to load their timesheets in Xero Payroll are experiencing issues. Our team is investigating this with urgency.
Status Last Reviewed: 11:00pm UTC
Posted Mar 17, 2024 - 22:59 UTC
This incident affected: New Zealand - Regional Products (NZ Payroll).