Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 16, 2024 - 02:00 UTC
Scheduled
The Inland Revenue Department (IRD) is completing scheduled maintenance from 3pm, Saturday 16 November to 9am, Sunday 17 November 2024. During this time you will be unable to file GST returns, income tax returns or payday filings to IRD from Xero. You can complete filings to IRD as normal from 9am Sunday 17 November.
Please note, you can continue to run and view GST, income tax returns and payruns during this time.
Posted Nov 12, 2024 - 20:31 UTC
This scheduled maintenance affected: New Zealand - Regional Products (Tax Reporting - NZ GST, NZ Payroll) and Xero Partner Products & Tools (Xero Tax (NZ)).