Our team has resolved the issue impacting customers trying to load the Employment and Taxes tabs in Payroll. We apologise for any inconvenience this has caused.
Posted Nov 28, 2023 - 23:53 UTC
Update
We are continuing to investigate this issue.
Posted Nov 28, 2023 - 22:21 UTC
Investigating
We are aware customers trying to load the Employment and Taxes tabs in Payroll are experiencing intermittent errors. Our team is investigating this with urgency.
Status Last Reviewed: 11:00pm UTC
Posted Nov 28, 2023 - 21:34 UTC
This incident affected: Australia - Regional Products (AU Payroll), New Zealand - Regional Products (NZ Payroll), and United Kingdom - Regional Products (UK Payroll).