AU: Batch Payments - some customers may be unable to process batch payments in Xero.

Incident Report for Xero

Resolved

Our team has resolved the issue impacting Australian customers trying to process batch payments in Xero. We apologise for any inconvenience this has caused.

A product release caused batch payments to become unavailable and a rollback has returned sevice.
We learn from every incident and put measures in place to prevent issues from happening again.
Posted Aug 24, 2026 - 02:02 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.
Posted Aug 24, 2026 - 01:53 UTC

Identified

We're aware that some customers in Australia are unable to process batch payments in Xero, and are receiving an error.

We have identified what is causing this issue and are releasing a fix.

This is our top priority and we will update you as soon as we can.
Posted Aug 24, 2026 - 01:44 UTC
This incident affected: Core Xero Products (Invoicing, Bills & Quotes).