Global: Hubdoc - Some customers are experiencing delays in publishing documents

Incident Report for Xero

Resolved

Our team has resolved the issue causing delays with Hubdoc publishing and contacts. Our technical team identified this was caused by poor network connectivity and worked to restore service. We apologise for any inconvenience caused.
Posted Oct 01, 2025 - 09:28 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 09:09 UTC
Posted Oct 01, 2025 - 09:09 UTC

Investigating

We are aware that some customers are experiencing slowness in Hubdoc and delays with publishing to all destinations. Additionally, some recently created contacts may not be updated in Hubdoc. Our team is investigating this with urgency.

Status Last Reviewed: 8.35 am UTC
Posted Oct 01, 2025 - 07:02 UTC
This incident affected: Hubdoc.