AU: Bills - Some customers are unable to make batch payments

Incident Report for Xero

Resolved

Our team has resolved the issue impacting AU customers trying to make batch payments in Bills. This was related to a product release which has been rolled back. We apologise for any inconvenience this has caused.
Posted Oct 17, 2025 - 02:48 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 2:24 am UTC
Posted Oct 17, 2025 - 02:24 UTC

Investigating

We are aware some Australian customers trying to make batch payments in Bills are experiencing issues. Our team is investigating this with urgency.

Status Last Reviewed: 2:06 am UTC
Posted Oct 17, 2025 - 02:07 UTC
This incident affected: Core Xero Products (Invoicing, Bills & Quotes).