Xero - Customers may be experiencing degraded performance
Incident Report for Xero
Resolved
Our team has resolved the issue causing degraded performance in Xero by increasing the capacity of our internal systems. We apologise for any inconvenience caused.
Posted Aug 29, 2023 - 12:47 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 12:14 UTC
Posted Aug 29, 2023 - 12:15 UTC
Investigating
We are aware customers may be experiencing slow load times or other performance issues with Xero. Our team is investigating this with urgency.

Status Last Reviewed: UTC 11:14
Posted Aug 29, 2023 - 11:14 UTC
This incident affected: Xero Platform and Settings.