Issue with starting a new organisation in Xero
Incident Report for Xero
Resolved
Our Product Team has resolved the issue that was preventing users from starting a new organisation in Xero.
We apologise for the inconvenience caused by this.
Please let us know if you still have any issues with starting a new organisation in Xero, and we’ll investigate further.
Posted Mar 22, 2017 - 15:03 UTC
Update
Our Product Team has identified the cause of the issue, and are working on resolving this as soon as possible.
Posted Mar 22, 2017 - 14:20 UTC
Update
Our Product Team are getting close to identifying the cause of the issue. We apologise for any frustration caused by this.
Posted Mar 22, 2017 - 13:07 UTC
Update
We’re sorry about the frustration this may be causing you and thank you for your support while we work on fixing this.
Posted Mar 22, 2017 - 12:27 UTC
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users.
Posted Mar 22, 2017 - 11:49 UTC
Update
Our Product Team are doing everything they can to get this feature back online. Thanks for your patience.
Posted Mar 22, 2017 - 11:22 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Mar 22, 2017 - 10:58 UTC
Investigating
We’re currently aware of an issue preventing users from starting a new organisation in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Mar 22, 2017 - 10:19 UTC