AWS outage causing intermittent errors when performing tasks in multiple Xero products
Incident Report for Xero
Resolved
The AWS team have resolved the outage that was causing errors in multiple Xero products.

Please let us know if you still have any issues, and we’ll investigate further
Posted Nov 26, 2020 - 21:53 UTC
Update
The fix implemented by AWS is returning our service to normal. We will continue to monitor the AWS recovery over the next few hours and update this page if there are any further updates.
Posted Nov 26, 2020 - 07:49 UTC
Monitoring
AWS has implemented a fix and we are monitoring the results.
Posted Nov 26, 2020 - 04:29 UTC
Update
We are starting to see gradual restoration in the service from AWS and impacted users should start to see an improved performance.
Posted Nov 26, 2020 - 03:11 UTC
Update
We wanted to let you know that we’re still working on this with AWS and we’ll update you as soon as we have more information.
Posted Nov 26, 2020 - 02:07 UTC
Update
The AWS team is continuing to work on restoring a service Xero uses to communicate across our product. We are working to restore functionality to affected users as quickly as possible and we’ll continue to keep you updated. Thanks for your continued patience.
Posted Nov 26, 2020 - 00:36 UTC
Update
The AWS team is currently working to get the affected users back up and running. Thanks for your continued patience.
Posted Nov 25, 2020 - 23:00 UTC
Update
The AWS team is working urgently to resolve this issue. Thanks for your continued patience.
Posted Nov 25, 2020 - 21:16 UTC
Identified
The AWS team have identified the cause of this issue and are working to restore functionality as soon as possible.
Posted Nov 25, 2020 - 19:03 UTC
Update
We are continuing to investigate this issue.
Posted Nov 25, 2020 - 18:43 UTC
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users.
Posted Nov 25, 2020 - 18:17 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Nov 25, 2020 - 17:33 UTC
Investigating
We're currently aware that some users are seeing errors on various pages in Xero. This is being investigated with urgency and we'll update you as soon as we know more.
Posted Nov 25, 2020 - 16:42 UTC
This incident affected: Xero Platform and Settings, WorkflowMax and Xero Partner Products & Tools (Xero Practice Manager (XPM), Xero HQ).