Global: Some customers are experiencing errors using Chrome on a MacBook
Incident Report for Xero
Resolved
Our team is still working through this issue impacting some customers who are using the recent update to Chrome to access some parts of Xero. We apologise for any inconvenience this has caused.

In the meantime please use another browser to access Xero while we work to address this issue.
Posted Apr 22, 2024 - 05:24 UTC
Investigating
We are aware some customers trying to access various products in Xero using Chrome on a MacBook are experiencing issues. Our team is investigating this with urgency.

Status Last Reviewed: 3:41am UTC
Posted Apr 22, 2024 - 03:40 UTC