Some users are experiencing slowness and errors in WorkflowMax, Xero Practice Manager and Xero Tax
Incident Report for Xero
Resolved
Our Product Team have resolved the issue causing slowness and errors in WorkflowMax, Xero Practice Manager and Xero Tax.
Please let us know if you still have any issues, and we’ll investigate further.
Posted Mar 03, 2020 - 05:04 UTC
Update
We're currently working to get WorkflowMax, Xero Practice Manager and Xero Tax back up for everyone. Thanks for your continued patience.
Posted Mar 03, 2020 - 04:42 UTC
Identified
Our Product Team have identified the cause, and are working to restore full performance for WorkflowMax, Xero Practice Manager and Xero Tax as soon as possible.
Posted Mar 03, 2020 - 03:40 UTC
Update
We’re sorry this is causing you some downtime. Thank you for your support while we fix this for you.
Posted Mar 03, 2020 - 03:16 UTC
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users.
Posted Mar 03, 2020 - 02:46 UTC
Update
Our Product Team are doing everything they can to let you access WorkflowMax, Xero Practice Manager and Xero Tax. Thanks for your patience.
Posted Mar 03, 2020 - 01:55 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Mar 03, 2020 - 01:22 UTC
Investigating
We’re currently aware of an issue causing slowness and errors in WorkflowMax, Xero Practice Manager and Xero Tax. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Mar 03, 2020 - 00:52 UTC
This incident affected: Partner Tools & WorkflowMax (Practice Manager and WorkflowMax, Xero Tax (Australia)).