Slowness and errors when accessing WorkflowMax and Xero Practice Manager
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing users to experience slowness and errors when accessing WorkflowMax and Xero Practice Manager.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted 3 months ago. Jul 17, 2019 - 17:19 NZST
Investigating
We’re currently aware of an issue causing users to experience slowness and errors when accessing WorkflowMax and Xero Practice Manager. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted 3 months ago. Jul 17, 2019 - 17:08 NZST
This incident affected: Partner Tools & WorkflowMax (Practice Manager and WorkflowMax).