Global: Practice Manager - entering time
Incident Report for Xero
Resolved
Our team has resolved the issue impacting global customers trying to enter time in Practice Manager. We apologise for any inconvenience this has caused.

We've rolled back the release causing this issue and services are back to normal.
Posted May 29, 2024 - 05:18 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 5:12am UTC
Posted May 29, 2024 - 05:12 UTC
Investigating
We are aware global customers trying to enter time in Practice Manager are experiencing an incorrect entry. Our team is investigating this with urgency.

Status Last Reviewed: 5:00am UTC
Posted May 29, 2024 - 05:00 UTC
This incident affected: Xero Partner Products & Tools (Xero Practice Manager (XPM)).