Some users are unable to access reports in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from accessing reports in Xero.

If you're still not able to access reports, please clear your web browser's cache and cookies, and let us know if this doesn't fix things for you.
Posted May 22, 2020 - 01:35 UTC
Investigating
We’re currently aware of an issue preventing a small number of users from accessing reports in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted May 22, 2020 - 01:15 UTC
This incident affected: Xero Platform and Settings.