Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted May 16, 2026 - 23:10 UTC
In progress
Scheduled maintenance is currently in progress. We expect this to run for an additional hour with a completion ETA of 12.00pm NZT. We will continue to provide updates as necessary.
Posted May 16, 2026 - 22:15 UTC
Scheduled
Xero will be undertaking scheduled maintenance on Sunday 17 May from 10.00am to 11.00am NZT.
During this time, customers will be unable to purchase new Xero subscriptions or manage existing subscriptions, including upgrades, downgrades, or suspensions. Customers onboarding into certain products may also experience temporary delays.
If you need to make changes to your subscription, please do so before or after the maintenance window. Any interrupted onboarding progress will resume automatically once the system is back online.