Some users are experiencing slowness in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing a number of users from logging into Xero.

Please let us know if you still have any issues accessing Xero, and we’ll investigate further.
Posted Jun 29, 2020 - 05:28 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 29, 2020 - 05:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2020 - 04:52 UTC
Update
Our Product Team are doing everything they can to get you back online with Xero. Thanks for your patience.
Posted Jun 29, 2020 - 04:18 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Jun 29, 2020 - 03:44 UTC
Investigating
We’re currently aware of an issue preventing a small number of users from logging into Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Jun 29, 2020 - 03:12 UTC
This incident affected: Xero.