Customers experiencing slow performance in Xero
Incident Report for Xero
Resolved
Customers are now able to access Xero without experiencing slow performance. We have resolved the problem which was related to network stability issues and required the system to be reconfigured so it remained stable during high traffic periods.

We apologise for any inconvenience this has caused.
Posted Nov 09, 2022 - 03:50 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 3.41am UTC
Posted Nov 09, 2022 - 03:41 UTC
Investigating
We are aware of an issue causing slow performance in Xero. Our team is investigating this with urgency.

Status Last Reviewed: 12:51 AM UTC
Posted Nov 09, 2022 - 00:51 UTC
This incident affected: Xero Platform and Settings.