Some users are unable to access Xero Central
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from logging into Xero Central.

If you are still encountering issues with this, please clear your browsers cookies and cache.

If this still doesn't work, let us know and we’ll investigate further.
Posted 15 days ago. Mar 06, 2019 - 16:30 NZDT
Update
We’re currently aware of an issue preventing users from logging into Xero Central. Our Product Team is investigating this with urgency.

In the meantime, please use Incognito or Private Browsing to login.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted 15 days ago. Mar 06, 2019 - 16:15 NZDT
Investigating
We are currently investigating this issue.
Posted 15 days ago. Mar 06, 2019 - 16:10 NZDT
This incident affected: Xero.