Global: Some customers are experiencing errors accessing Xero

Incident Report for Xero

Resolved

Our team has resolved the issues causing some customers to experience errors when navigating or logging into Xero.

This was caused by a database issue and our team made a configuration change to restore services to normal. We apologise for the inconvenience caused and appreciate your patience whilst we resolved this.
Posted Nov 24, 2025 - 09:59 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.
Posted Nov 24, 2025 - 09:24 UTC

Investigating

We're aware some customers are currently experiencing issues in Xero Blue and are receiving errors after logging into Xero. Our team is investigating this with urgency.
Posted Nov 24, 2025 - 08:59 UTC
This incident affected: Xero Platform and Settings.