Global: Multiple products- some customers may experience slowness in Xero
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers trying to create organisations or change user roles. Some customers may have also been unable to access the Demo Company, or Xero Me. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Aug 15, 2024 - 06:08 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 5:54am UTC
Posted Aug 15, 2024 - 05:54 UTC
Identified
We have identified what is impacting customers trying to create organisations or change user roles. Some customers may also be unable to access the Demo Company, or Xero Me.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 5:40am UTC
Posted Aug 15, 2024 - 05:40 UTC
Investigating
We are aware some customers trying to create organisations or change user roles are experiencing a delay. Some customers may also be unable to access the Demo Company, or Xero Me. Our team is investigating this with urgency.

Status Last Reviewed: 5:30am UTC
Posted Aug 15, 2024 - 05:30 UTC
This incident affected: Xero Platform and Settings and Xero Mobile Apps (Xero Me).