Our team has resolved the issue impacting customers trying to raise a support case in Xero Central.
This was related to a third-party integration with Salesforce, and a fix has been released. We apologise for any inconvenience.
Posted Oct 17, 2024 - 05:27 UTC
Monitoring
Salesforce have implemented a fix and we are currently monitoring the results.
Status Last Reviewed: 5:17am UTC.
Posted Oct 17, 2024 - 05:20 UTC
Update
We are aware customers trying to raise a support case in Xero Central are experiencing slowness. Salesforce have acknowledged the issue and are investigating this with urgency. Please visit the Salesforce Status page for updates. We apologise for the inconvenience.
Status Last Reviewed:
Posted Oct 17, 2024 - 04:58 UTC
Update
We have raised this with Salesforce who are assisting in investigating the cause.
Posted Oct 17, 2024 - 04:45 UTC
Update
We are continuing to investigate this issue.
Posted Oct 17, 2024 - 04:44 UTC
Investigating
We are aware customers trying to raise a support case in Xero Central are experiencing slowness. Our team is investigating this with urgency.
Status Last Reviewed: 4:40am UTC
Posted Oct 17, 2024 - 04:42 UTC
This incident affected: Xero Platform and Settings and Xero Central.