Americas: Xero Central - Some customers are unable to access Xero Central

Incident Report for Xero

Resolved

Our team has resolved the issue causing customers to receive errors when trying to access Xero Central through https://xero.my.site.com

This was due to the SalesForce Experience Cloud incident.

We apologise for any inconvenience this has caused.
Posted Mar 08, 2025 - 05:55 UTC

Update

We are continuing to investigate this issue.
Posted Mar 08, 2025 - 03:27 UTC

Investigating

We are aware customers in the USA, CA and BR are receiving errors when trying to access Xero Central through https://xero.my.site.com

Our team is investigating this with urgency. In the meantime, please access Xero Central through - https://central.xero.com/s/

Status Last Reviewed: 5.28am UTC
Posted Mar 08, 2025 - 01:39 UTC
This incident affected: Xero Central.