Investigating Possible Issue
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 02:27 UTC
Investigating
Some users may be experiencing errors in Xero, we are investigating and will post an update as soon as we have more information.
Posted Jun 03, 2021 - 02:13 UTC
This incident affected: Xero Platform and Settings.