Some users are experiencing slowness in Xero
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Jun 26, 2020 - 14:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2020 - 14:12 UTC
Investigating
We are currently investigating an issue where some users are experiencing degraded performance and some features may be inaccessible.
Posted Jun 26, 2020 - 13:09 UTC
This incident affected: Xero.