Performance issues with WorkflowMax, Xero Practice Manager and NZ and AU Tax
Incident Report for Xero
Resolved
Our Product Team have resolved the performance issues with WorkflowMax, Xero Practice Manager, NZ and AU Tax.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted 17 days ago. May 09, 2018 - 17:43 NZST
Investigating
We’re currently aware of performance issues with WorkflowMax, Xero Practice Manager, NZ and AU Tax. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted 17 days ago. May 09, 2018 - 17:24 NZST