Our team has resolved the issue where some customer were unable to access the 'Go to Xero' button. We apologise for any inconvenience this has caused.
A product release caused this feature to become unavailable. We've rolled back the release and services are back to normal.
Posted Nov 28, 2023 - 13:35 UTC
Investigating
We are aware customers trying to access the 'Go to Xero' button in Xero HQ are finding that the button is unavailable. Our team is investigating this with urgency.
Status Last Reviewed: 13:10
Posted Nov 28, 2023 - 13:12 UTC
This incident affected: Xero Partner Products & Tools (Xero HQ).