Some pages aren't loading correctly in Payroll
Incident Report for Xero
Resolved
Our Product Team have resolved the issue which meant that some pages weren't loading correctly in Payroll.

If you're still having any problems, please clear your cookies and cache using the link below. Please let us know if you continue to have issues and we'll investigate further.

Xero Help Centre: https://help.xero.com/ClearCookiesCache

Please accept our apologies for any inconvenience this has caused.
Posted Jun 15, 2017 - 21:05 UTC
Identified
Our Product Team have identified the cause and are working to get his resolved.
Posted Jun 15, 2017 - 20:56 UTC
Investigating
We're currently aware of an issue which means that some pages in Payroll aren't loading correctly. Our Product Team are currently investigating and we'll be posting further update here.

Please accept our apologies for any inconvenience this is causing.
Posted Jun 15, 2017 - 20:42 UTC