Some users are unable to access Projects
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Jun 17, 2022 - 16:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 17, 2022 - 15:51 UTC
Investigating
Some users may be experiencing slowness and error messages when trying to access Xero Projects from Safari browsers. We are investigating and will post an update as soon as we have more information.
Posted Jun 17, 2022 - 15:37 UTC
This incident affected: Xero Platform and Settings.