NZ: NZ GST - Some customers trying to load or file returns are experiencing slowness and errors.
Incident Report for Xero
Resolved
Our team has resolved the issue impacting some NZ customers trying to load GST returns in Xero. We apologise for any inconvenience this has caused.

A product release caused this feature to become unavailable. We've rolled back the release and services are back to normal.
Posted Aug 07, 2024 - 00:52 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 12:25am UTC.
Posted Aug 07, 2024 - 00:25 UTC
Identified
We have identified what is impacting NZ customers trying to load and file returns in NZ GST.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 12:21am UTC
Posted Aug 06, 2024 - 23:10 UTC
Investigating
We are aware some NZ customers trying to load returns in NZ GST are experiencing slowness and errors. Our team is investigating this with urgency.

Status Last Reviewed: 10:23pm UTC.
Posted Aug 06, 2024 - 22:25 UTC
This incident affected: New Zealand - Regional Products (Tax Reporting - NZ GST).